Custom Blueprint save changes file on server but displays the old content afterwards


I realize that two similar questions have been posted here and here, but neither had a solution which helped for me.

I have the following behavior: When changing the content in a markdown editor in my custom blueprint and saving, the file on the server itself changes but the content in my editor jumps back to the previous version. The behavior occurs mostly with small changes like single character changes. It is quite inconsistent behavior and the other posts suggest some issue in the blueprint. So if anyone could give me any pointers there, I would be really happy!


title: Steckbrief

      type: text
      autofocus: true
      style: vertical
      type: editor
      label: Fakten
      type: editor
      label: Beschreibung

Grav Version 1.7.10
Admin v1.10.9
All caching has been disabled

Thanks a lot,

@jannic, I’m afraid I cannot replicate the behaviour you are describing using the latest Grav 1.7.16 + Admin 1.10.16.

Although your blueprint is working fine, please be advised, that field content in the header of a page is usually used to define a collection.

    items: '@self.children'
        by: date
        dir: desc
    limit: 10
    pagination: true

NB. When experiencing an issue, please try to upgrade to latest version first. It might have been fixed already.

Hi @pamtbaau , thank you very much for the quick reply.

I did upgrade to the latest versions and unfortunately, the issue persists.
Maybe it is worthy to note, that the application is running in a azure app service?
Also, even though caching is disabled, whenever the issue happens a “clear cache” as an admin does resolve the issue.

Should I try to use a different key word than “content”? Or is that unlikely to resolve this?

Thanks, Jannic

@jannic, I’m afraid I cannot help you with anything Azure related…

Try this post Deploy Grav to Azure using Azure DevOps from @techielass. Sara is Msft consultant for Azure.

In the end, it was the reserved content keyword which created the inconsistencies. Changing it to contents solved the issue.