Class 'Grav\Plugin\Email\Email' not found

Just updated to 1.1.4 with admin on my local environment, did some changes to the site content and all is good and displaying correctly on my local environment. Pulled down to my production server via git and now getting this Class ‘Grav\Plugin\Email\Email’ not found error.

There is a heap of stuff along with it, rather than copy+pasting a wall of text feel free to visit my staging server to see the stream of errors all related to the email plugin. I tried doing a clean install of the email plugin from the repo, my local env kept going fine but still no joy on the live server.

Error stream can be found here:

I had the same problem yesterday. In the end, I reinstalled the email plugin directly on the production site, and that got rid of the error. But I have no idea what the original problem was.

Nice - thats got things going again. Thanks for that!

Glad. Interesting site …

Are you pushing via git to the production server? In this case it might skip the vendor/ folder of the Email plugin if it’s in .gitignore. Just a hint of a possible cause of the problem…

Does this happen once after update? Or consistently?

It happened once to me. The latest update to Grav and 5 plugins went fine using my standard approach. Aupdate Grav locally and in production separately. Then update plugins locally and use git to push to production site.

There was a change of how Email classes were loaded by the plugin. Now uses composer based autoloader. If it continues just reinstall email plugin.