Class 'Grav\Plugin\Form\Form' not found

form
#1

Hello,
I tried to pull the user- and tmp folder from my git-repo via Plesk on the server. Then I pulled all other folders and files from GRAV via FTP on the server.
When I call the website, I get the error message: Class ‘Grav\Plugin\Form\Form’ not found

I am working for a company and I do not get the rights to use gpm on the server in the moment.
I have tried to delete the plugins\form folder and pull a fresh version to the server again via FTP, but it doesn’t work. Got the same issue again. Any ideas how to fix this issue?

#2

For all users who have the same issue: I was able to fix it.
I got the permission to use gpm on the server. After reinstalling the form plugin via gpm, everything worked fine. I think some files got lost during the filetransfer to the server. Tomorrow I will try to find out which files got missed and then I will post the solution here. Maybe it could help some users in the future.

#3

Problem is with case sensitive volumes (https://github.com/getgrav/grav/issues/1052#issuecomment-372228853)
Solution is create case sensitive partition or disable ignoring case at your git config via
git config core.ignorecase false

1 Like
#4

If, when trying to log into the backend, you get a Class ‘Grav\Plugin\Form’ not found error, sftp or ssh into the instance and navigate or cd into the /path/to/your/site/user/plugins/form/classes folder and then change the name of the form.php file to Form.php