Can't make dump() work any longer

Dump used to work fine but I seem to have turned it off somehow. What have I done wrong? In /Applications/MAMP/htdocs/user/config/system.yaml I have

  enabled: true
  twig: true
    close_connection: true

[NB in the documentation at the screensnip shows enabled: false but I presume that’s a mistake? Anyway, I’ve tried both.]

My template includes this:

<h4>dump </h4>{{ dump(page.header) }}

And the rest of the template is working - it shows the content and the children fine. But I don’t get a little G icon leading to the debug bar.

Help appreciated!

Is cache enabled?

It wasn’t. On seeing your question I tried again with

  enabled: true

in /Applications/MAMP/htdocs/user/config/system.yaml, but I still don’t get a debug bar.

Have you somehow disabled JQuery in your theme/site? The debugbar needs JQuery to work. You can probably check your browser’s console for any JS errors that are being output.

No messages at all in the Chrome javascript console.

Do you have any other environment configuration files like localhost/config/system.yaml ?

Only the ones that were supplied. Shall I do a fresh install?

Fixed the docs.

Keep cache disabled to make sure older settings are not cached. Also try clearing thge cache.

Additionally, you theme must correctly output javascript and css.
You can check one of the GetGrav-provided skeletons (i.e. Blog Site) as an example.

I’m using Antimatter, unchanged afaik. I’ll try starting over.

I restarted with a new install and the problem has gone away.