Can't get it going - 501

i’ve looked through the posts, tried solutions offered with htaccess, ensured that the PHP version is relevant (5.6) and made sure that all the bits mentioned are active in php.

And it still won’t work. I have a couple of Joomla sites on that hosting account and they work fine.
Any more suggestions?

You’re getting a 501 error? Or a 500 error?

Oops - well spotted! It’s a 500 error

Could be this?

Tried that - made no difference

a 500 error usually means that something in the .htaccess file is being specifically denied by your hosting provider. Try commenting out the Options line in the .htaccess.

Other than that, the only thing that is left is the Rewrite Engine. Are you super sure this is enabled?

well, I’ve tried everything I can find in this forum, but none of the changes have worked.
Yes, RewriteEngine On is not commented; Options makes no difference. It worked on XAMPP, but it doesn’t on this server, and, as I mentioned, I have joomla sites here working fine, using the htaccess file generated by admintools which is amazingly exhaustive.
So, I’m stuck.
is there a bare minimum htaccess I can try, so that I can gradually enable other lines to see where the problem lies? What I mean, what are the absolute minimum rules without which Grave won’t work at all.

## Begin - Index
# If the requested path and file is not /index.php and the request
# has not already been internally rewritten to the index.php script
RewriteCond %{REQUEST_URI} !^/index\.php
# and the requested path and file doesn't directly match a physical file
RewriteCond %{REQUEST_FILENAME} !-f
# and the requested path and file doesn't directly match a physical folder
RewriteCond %{REQUEST_FILENAME} !-d
# internally rewrite the request to the index.php script
RewriteRule .* index.php [L]
## End - Index

Right thanks. Tried that - still no success. BUT

I worked with my hosting company and it turns out that the problem was that files all had permissions set 664, where of course, it should be 644!

This is likely a packing error in the zip file, so perhaps this could be passed on to be corrected :slight_smile:

Thanks all.

Actually 664 is perfectly normal, but clearly your hosting provider has some restriction on this and requires 644 else throws this 500 server error.

Possibly, however, I note that all Joomla standard is 755 for folders and 644 for files, and as my hoster is the main joomla sponsor here, I’m glad there is no conflict with the joomla standard. Check it out with the rockettheme guys.
Whatever, my problem is solved, but it may help others who have this issue.