Can't create a new theme


just wanted to start a new theme for my own website. Therefore I set up a new Grav environment, installed devtools and then tried to execute bin/plugin devtools new-theme. First I got an error about an T_STRING problem, which was solved by modifying the first line in bin/plugin to #!/usr/bin/env php55, since Domainfactory uses different PHP versions on their servers.

With php55 the version 5.5.30 is executed, so I thought it might work now. In fact, it did not:

X-Powered-By: PHP/5.5.30
Content-type: text/html

FATAL: Must be run from ROOT directory of Grav!

In fact I am in the root directory of this Grav installation, otherwise I wouldn’t be able to call bin/plugin.

Any hints on this?

Regards, Thomas

In case of Domainfactory you have to modify the header of bin/plugin to the following line:
!/usr/bin/env php5-55LATEST-CLI
This is a link to the currently latest PHP 5.5 CLI version (as of 24.01.2017 it’s version 5.5.38)

Thanks to rhukster for guiding me.

Regards, Thomas