Blackhole html export

Hello :slight_smile:

I read the instruction for Blackhole plugin but I could not make it work.

This is how I filled form: https://ibb.co/6XFX6Zj

When I clicked generate, it asked me this weird question https://ibb.co/V9X88wR

As you can see, there is no input for " Input URL" as seen in instruction. Can you please help me to find a way to make it work, please?

@Robovision,

When I clicked generate, it asked me this weird question https://ibb.co/V9X88wR

Have you tried to click ‘Leave’? And what happened?

As you can see, there is no input for " Input URL " as seen in instruction.

Input URL is only needed when using the CLI because the CLI does not know the URL of the site. In Admin, the Url of the site is known and hence an input field is not required…

When I click on Leave, the page reloads and the only difference is URL with ?blackhole=generate after http://localhost/gravdemo/admin/plugins/blackhole

Like this:
http://localhost/gravdemo/admin/plugins/blackhole?blackhole=generate

I understand there should be folder called “zzz” with html but there is none.

Also, I changed “absolute_urls: false” to “true” in users/config/system.yaml

I tried to change “…/zzz” just to “zzz” but the folder can not be found anywhere.

@Robovision, I’m sorry, but I cannot reproduce the issue.

Using a fresh Grav 1.6.26 installation and using your settings, ‘Generate’ creates a folder ‘zzz’ in the root of the site, with the following content:

zzz
├── home
│   └── index.html
├── index.html
└── typography
    └── index.html

Can you check what I am doing wrong please?

@Robovision, Sorry, but you’re not doing me a service with this video…

Try the following and see if it works:

  • Create a fresh install of Grav 1.6.26
  • Install Blackhole plugin
  • Enter settings, save and run Generate

It should be working. If not… I cannot be of much more help.