Use fullpage by OleVik with Gantry5

Hi, im using a Grav+Gantry5 and Hydrogen. I installed fullpage pluguin of OleVik. But i cant understand how i need for assign the fullpage in the sections.
My web no have page content, have sections in the layout. I tried to assign “section” css class to the sections, but nothing happens.

Any can help me? Thanks


I am not aware of any structural changes to Gantry5 or Hydrogen that would prevent this, but then again I do not use Gantry. Rather than relying on CSS-classes, the plugin relies on Markdown for achieving the structure. For example, see the demo content of the Alice in Wonderland book here.

That is to say, the content structures the FullPage.js functionality.

Best regards, Ole Vik

In you example link, this are pages, but im not using pages for make a content, im using only sections with particles “/user/data/gantry5/themes/g5_hydrogen/config/home_particles/layout.yaml”.

I put differents methods for make a fullpage navigation, writing “section” in the CSS Classes, but not work.

CSS-classes will have no effect here, as the plugin willfully ignores pre-existing styling. The only separator of sections and slides, per the FullPage.js nomenclature, are page-structures and horizontal rules. This is detailed here.

With the caveat that I have not used Gantry for a long while, I think you would need to break the slides using a “Custom HTML” particle that inserts a horizontal rule – <hr /> – or a FrontMatter-variable of horizontal: true if you want it to behave as sections.

I cannot guarantee that this will work, as noted earlier I do not use Gantry, but the logic should be commensurate with the buildContent()-method of the plugin.

I tried fullpage in a normal page (not section of gantry), but do not work. I used a normal Grav site without gantry, but nothing works, i cant understand how to use you pluguin :frowning:

Could you try this skeleton?

I tried you skeleton, and there have fullpage page template.

But in my web with these plugin not appear this page template.

I have tested this with with v1.2.0 of the plugin, on Grav v1.4.5 with Admin v1.8.3, and like with the skeleton it does show up there (source):

I don’t know why it would not appear in your local installation, but I would advise that you upgrade Grav and extensions to their latest versions.