Upgrade to v1.7.0-rc1

I’m running a beta 10 on Windows 10 Laragon server for local web development/testing
Within the Dashboad ‘check upgrade’ reports rc1 & 3 available.
‘Update Grav Now’ appears to download rc1 (not sure where to) and reports Grav successfully upgraded to v1.7.0-rc1.
However a refresh reports version still at beta 10.
Tried using command line mode gpm self-upgrade & get error( line 316) “while trying to download code: ):”

Not had a problem before but checked the firewall incoming & outgoing but could not recognise anything specific relating to it, temporarily turning off firewall didn’t help
php_openssl is enabled and I tried in both Firefox and edge browsers

1 Like

I’m having exactly the same problem, but not locally in Laragon. Please help us :)))

Might this address the issue? https://github.com/getgrav/grav/issues/2722

Thanks Paul,
It looks like the only solution is a manual update of rc1
Problem is solution given is only valid for a linux server not windows which I use for local testing server.

I suspect my options are

  1. Mirror site to linux server - fix and mirror back
  2. Install clean rc1 and update from copy
  3. Forget upgrade and wait for full stable release

Probably 3 is best bet and not a problem
Unless, of course, there are fix instructions for Windows server.

A manual update really means that you download a fresh copy of Core, backup your /user-folder, install Core, and replace /user with your backup. This process is the same across operating systems, but yes, the instructions given in the GitHub Issue comment is rather Unix-specific. When an update fails spectacularly, your best bet is almost always doing a clean installation and putting back in configuration and content - which in Grav is self-contained within /user.

Thanks @OleVik
Thats one of the reasons why I love GRAV, so simple and quick to recover