Update form plugin 2.13.2 to 2.13.3

I am trying to set up a new development site on localhost. I downloaded Grav with Admin and logged in as new user. I now want to install gantry 5 framework but it wont let me until I have updated form from 2.13.2 to 12.13.3. It appears to update but still says it is using 12.3.2 and I need to update! I get this error on completion “Error while trying to download (code: 302): https://getgrav.org/download/plugins/form/2.13.3
Any advice on getting this to work would be appreciated as I am now stuck!
Thanks