Twig Error when I click into Quark (Merge Filter)

#1

In the admin panel, when I click into Themes and then Quark (2.0.0) I get the following error:

Twig \ Error \ RuntimeError
The merge filter only works with arrays or “Traversable”, got “string” as first argument.

I tried re-installing Quark but get the same error, so I’m thinking someone is broken somewhere else. Any ideas? The site itself is functioning fine, but I want to see if this is related to an issue of a broken image in the header.

#2

I don’t see this, but it’s likely it your quark.yaml configuration. Why not paste that here, and i’ll see if anything jumps out as an issue…

#3

in user/theme/quark, the quark.yaml is:

enabled: true
production-mode: true
grid-size: grid-lg
header-fixed: true
header-animated: true
header-dark: false
header-transparent: false
sticky-footer: true
blog-page: ‘/blog’
spectre:
exp: false
icons: false

nothing there looks ridiculous?

#4

the bottom bit should be:

spectre:
  exp: false
  icons: false

Notice the indents… they are important.

#5

Fixed the indents, cleared the cache, but same issue. I’m going to poke around any files I’ve changed - or even just looked at, see what I broke.