Tag directs to about:blank problem

I’m wondering if you can help me with a question about my item.md pages directing tags in “Popular Tags” section to about:blank. With Grav running, the code in “Popular Tags” is, for example: <a href=​"/​/​tag:​photography">​photography​​.

As expected, when I enter “http://localhost:8000/tag: photography” in the web browser, it works, that is, it brings pages with “photography” tag.

I cleared the cache.

My system:
Mac with OS X 10.9.5

php -v
PHP 5.4.30 (cli) (built: Jul 29 2014 23:43:29)
Copyright © 1997-2014 The PHP Group
Zend Engine v2.4.0, Copyright © 1998-2014 Zend Technologies

bin/grav --version
Grav CLI Application version 0.1.0

bin/gpm --version
Grav Package Manager version 0.9.5

bin/gpm index shows 11 installed plugins: Archives, Breadcrumbs, Error, Feed, Highlight, Pagination, Random, Sitemap, SimpleSearch, Taxonomy List, Problems; 
and 1 installed Theme: Antimatter (v.1.1.7).

I couldn’t find any logs in the /logs directory.

I searched forum for posts related to base_url and tried the suggestion from this forum post:
Active Page If page:1? (http://getgrav.org/forum#!/general:active-page-if-page1), and I also ran bin/gpm install self-upgrade, bin/gpm install selfupgrade, bin/gpm install update.

So does the problem your facing is that the Tag URLs are not working only on the blog item page? Do the tags work fine on the blog listing page?

There was a change in Antimatter between 1.1.6 and 1.1.7 that could of impacted this as I did change how the base_url was calculated:

If you have updated Antimatter to 1.1.7, and cleared your cache for good measure, it should work fine.

You should be able to conform the Antimatter version with:

bin/gpm version antimatter

The demo is up-to-date and it looks fine too right? http://demo.getgrav.org/blog-skeleton/

The Tag URLs are not working on the blog item page and on the blog listing page.

The Antimatter is version 1.1.7 and the changes from https://github.com/getgrav/grav-theme-antimatter/commit/8e51e74f8bd8e73a9745639458a28e918342b40b are in it.

Yes, everything else looks fine on the demo – Just to be completely sure, I’ve just installed another instance of Grav and then installed the blog skeleton – It still is not working. I tried page 2 link at the bottom of the blog page and similarly, it’s encountering an error – it redirects to page:2.

I noticed an “Unexpected EOF” error in php’s output - here is an excerpt:

[Sat Nov 15 23:41:58 2014] ::1:52285 [200]: /images/b/0/d/d/a/b0ddab295f790ff5902c0986d62d993c698f6f04-unslpashyai rhazout.jpeg
[Sat Nov 15 23:41:58 2014] ::1:52286 [200]: /images/1/b/d/1/6/1bd1682469b57a872b3886a1e4291a3ebdc6d3b0-blog-header .jpeg
[Sat Nov 15 23:41:58 2014] ::1:52287 [200]: /user/themes/antimatter/fonts/fontawesome-webfont.woff?v=4.1.0
[Sat Nov 15 23:41:58 2014] ::1:52289 [200]: /user/themes/antimatter/images/favicon.png
[Sat Nov 15  23:42:23 2014] ::1:52290 Invalid request (Unexpected EOF)
[Sat Nov 15 23:42:23 2014] ::1:52291 Invalid request (Unexpected EOF)

I’m also attaching a screen capture of the installed plugins and Themes – From bin/gpm index. Gpm

The GPM screenshot is actually showing your Antimatter and Pagination plugins are not up to date. Could you try updating them again with:

bin/gpm update

If that doesn’t do it I’ll have to dig in deeper tomorrow. Perhaps you can put a .zip of your site up on dropbox or something and send me the URL to devs(at)grav.org ?

I’ve run bin/gpm update and cleared the cache - still going to for example: //tag:photography. Absolutely – can continue tomorrow or when you have time. I’m going to provide you a .zip of my site tomorrow. Gpmupdated

Ok, feel free to send me a zip file. I really should only need your user/ folder, as that contains all the plugins, theme, and pages. Thanks! Email address provided a couple of posts up.

Thanks! I’ve just emailed you a dropbox link for user.zip.

Hmm… not seeing your email - try rhuk (a) getgrav.org

No spaces and translate the (a) to @ of course :slight_smile: Trying to keep the auto-spamming bots away!

Sorry - I sent it to devs(at)grav.org first time – not to at getgrav.org. I’ve just resent it to your rhuk email. Thanks!

Ok, so I downloaded a brand-new copy of Grav 0.9.5 zip from the getgrav.org site. I extracted this into my webroot as /grav-dux and then I took your user.zip file you provided me and dropped it into the /grav-dux folder replacing the default one.

It appears to work fine. No issues at all. The URLs look correct:

<div class="sidebar-content">
    <h4>Popular Tags</h4>
 span class="tags">
        <a href="/grav-dux/tag:photography">photography</a>
        <a href="/grav-dux/tag:journal">journal</a>
        <a href="/grav-dux/tag:city">city</a>
        <a href="/grav-dux/tag:travel">travel</a>
        <a href="/grav-dux/tag:night">night</a>
        <a href="/grav-dux/tag:birds">birds</a>
        <a href="/grav-dux/tag:ocean">ocean</a>
        <a href="/grav-dux/tag:architecture">architecture</a>

This leads me to think that your Grav is not fully up to date with 0.9.5, or perhaps there’s a cache issue. Why don’t you try recreating my steps? I.e. Grab a new Grav, extract it, and they copy over you user/ folder?

I’ve done that and it’s still the same so something is wrong with my Mac OS X 10.9.5 environment.

I’ve also tried it two more times: 1. with MAMP & MAMP PRO; 2. with a clean OS X 10.10 virtual machine running in VMware Fusion Pro 7.0.0 – It still experiences the same problem.

I will have to discover what it is in my OS X 10.9 and OS X 10.10 environments that is causing it.


I’m using Yosemite 10.10, with built-in Apache, as well as latest MAMP. Both work fine. I’m not sure what else it could be as I cannot reproduce this at all :frowning:

BTW I only switched to 10.10 couple of weeks ago. Up until then I used 10.9 with no issues, it must be something else.

No problem – I will have to check my system. Many thanks for the quick help!

This project is great and I will be using it for my website/blog. I’ve tried several website engines (Jekyll, DocPad, Hugo, Nikola, Nanoc, …) and for me Grav is by far the best and what I have been looking for, that is: install an app, and start writing the content in Markdown.

That’s the goal :slight_smile: Let me know if you get it sorted. I’m posting a 2-part blog post shortly that walks you through installing blog skeleton on mamp, step-by-step. That might bring something to light.

I’ve fixed it – by following your today’s blog post on Developing Grav with GitHub: In short, if I copy the grav-skeleton-blog-site-v.zip file to my /Applications/MAMP/htdocs directory before installing core Grav system, it works. Thanks!

Actually you don’t even need to install Grav after. The skeleton has Grav in it already! :slight_smile: Glad you got it sorted.