[SOLVED] Exception in session_start();

Hello there,

i’ve got this msg on a clean intallation of grav on a shared host. I’ve examined the the php_info and i found, that the APC support lacks.

I guess there is no workaround, isnt there?

Thx in advance.

Whoops\Exception\ErrorException thrown with message "session_start(): open(/tmp/sess_25d414f6918d0b86728b06863d588172, O_RDWR) failed: No such file or directory (2)"

#9 Whoops\Exception\ErrorException in /grav/vendor/rockettheme/toolbox/Session/src/Session.php:92
#8 session_start in /grav/vendor/rockettheme/toolbox/Session/src/Session.php:92
#7 RocketTheme\Toolbox\Session\Session:start in /grav/system/src/Grav/Common/Session.php:86
#6 Grav\Common\Session:init in /grav/system/src/Grav/Common/Processors/InitializeProcessor.php:35
#5 Grav\Common\Processors\InitializeProcessor:process in /grav/system/src/Grav/Common/Grav.php:132
#4 Grav\Common\Grav:Grav\Common\{closure} in /grav/system/src/Grav/Common/Grav.php:370
#3 Grav\Common\Grav:Grav\Common\{closure} in /grav/system/src/Grav/Common/Grav.php:346
#2 call_user_func_array in /grav/system/src/Grav/Common/Grav.php:346
#1 Grav\Common\Grav:__call in /grav/system/src/Grav/Common/Grav.php:133
#0 Grav\Common\Grav:process in /grav/index.php:52

I had a similar issue (I think) on CentOS7. The PHP session.save_path did not exist and thus was not writable by the webserver user (/var/lib/php/session in my case). You can find the PHP session.save_path in your php_info. I am not sure if this is the same issue.


Thk u. I am gonna check on this. Thats weired. I run grav on two different web hosters without any install issues. Only this time… I will keep u up to date.

I just figuered it out. I wrote a test application. Simply, its an issue related to read/write permissions. The session_start() function stores all session keys in the session.save_path in order to trace the state of the http connection. So i only had adjust the user permissions, but… … … … … … … … … …
it a polish hoster and the whole backend sounds to me like an alien language ;(