Server Error - when Learn2 Git Upgrade


I install in localhost a copy of my production grav website (Grav v1.6.23 - Admin v1.9.13 and theme Learn2 Git Sync v1.5.6). Everything works well.

I wanted to upgrade Grav in localhost, just to make sure everything is working.
I updated to :

Theme : Learn2 Git Sync v1.5.9
Grav : 1.6.27
Admin v1.9.16

Now , I 'm not able to connect to Configuration /System

Server Error
Sorry, something went terribly wrong!
0 - An exception has been thrown during the rendering of a template (“Array to string conversion”).
For further details please review your logs/ folder, or enable displaying of errors in your system configuration.

In console debbuger / Tab Deprecated I get :

array:4 [
“message” => “Grav\Common\Session::getFlashObject(‘files-upload’) is deprecated since Grav 1.6, use $form->getFlash()->getLegacyFiles() instead”
“file” => “/Users/VPV/website/test/doc/system/src/Grav/Common/Session.php”
“line” => 116
“trace” => array:7 [
0 => array:3 [
“call” => “Grav\Common\Session->getFlashObject(‘files-upload’)”
“file” => “user/plugins/admin/admin.php”
“line” => 684
1 => array:3 [
“call” => “Grav\Plugin\AdminPlugin->onOutputGenerated(RocketTheme\Toolbox\Event\Event $object, ‘onOutputGenerated’, RocketTheme\Toolbox\Event\EventDispatcher $object)”
“file” => “vendor/symfony/event-dispatcher/EventDispatcher.php”
“line” => 212
2 => array:3 [
“call” => “Symfony\Component\EventDispatcher\EventDispatcher->doDispatch($array, ‘onOutputGenerated’, RocketTheme\Toolbox\Event\Event $object)”
“file” => “vendor/symfony/event-dispatcher/EventDispatcher.php”
“line” => 44
3 => array:3 [
“call” => “Symfony\Component\EventDispatcher\EventDispatcher->dispatch(‘onOutputGenerated’, RocketTheme\Toolbox\Event\Event $object)”
“file” => “vendor/rockettheme/toolbox/Event/src/EventDispatcher.php”
“line” => 23
4 => array:3 [
“call” => “RocketTheme\Toolbox\Event\EventDispatcher->dispatch(‘onOutputGenerated’, RocketTheme\Toolbox\Event\Event $object)”
“file” => “system/src/Grav/Common/Grav.php”
“line” => 403
5 => array:3 [
“call” => “Grav\Common\Grav->fireEvent(‘onOutputGenerated’)”
“file” => “system/src/Grav/Common/Processors/RenderProcessor.php”
“line” => 38
6 => array:3 [
“call” => “Grav\Common\Processors\RenderProcessor->process(Nyholm\Psr7\ServerRequest $object, Grav\Framework\RequestHandler\RequestHandler $object)”
“file” => “system/src/Grav/Framework/RequestHandler/Traits/RequestHandlerTrait.php”
“line” => 45

Do you have any idea?



I am not sure what is going on there - I just downloaded a fresh Learn2 with Git Sync skeleton locally, updated Grav and Plugins, and everything seems fine. Could you please do the same on your end and let me know how that test goes?

Perhaps something happened during the update process?


Thank you for your answer. I did test a fresh install (localhost with MAMPRO) with Learn2 with Git and I did not work when upgrade to latest version of Grav.

I find a way to solve the bug.

I download a fresh RTFM skeleton. This skeleton is similar to Learn2 with Git. I install all plugin needed. Then, I copy/paste all of my pages.
It works.

1 Like


I know this thread is a little bit older but today I ran into the same problem. I downloaded the Learn2 with Git Sync skeleton as a zip file from the Grav Downloads page ( and installed it in my local environment.

As @supportdb wrote, I also could not access the Configuration/System page and got the same error message.

My environment :
Grav version : 1.6.27
Admin panel : 1.9.16
Theme version : Learn2 Git Sync v1.5.9
PHP : 7.3.24
Linux server

An update to Grav v1.6.31 and Admin panel v1.9.19 did not change anything.

So I compared the user/config/system.yaml file with the system.yaml of another installation. After changing the configuration value from

  - '1'


hide_empty_folders: false

the Configuration/System page worked as expected.

@paulhibbitts : Can you reproduce this issue ?

Greetings, Peter

Thanks @renards, I’ll take a look into this and post what I find.

While I cannot seem to trigger the issue on my server I have made that change and released an updated Learn2 with Git Sync Skeleton @ Could you please test when convienent and when an update happens please let me know how things go? Thanks!

Hi @paulhibbitts,

I did a fresh install of the updated Learn2 with Git Sync skeleton and everything worked without any problems. I will keep you informed about future updates.

Thanks for the fast feedback and of course this awesome skeleton. :slightly_smiling_face:

1 Like