Problems with initial vendors with composer

I’m currently writing a plugin which requires the ts3admin.class from par0noid (link below). I created duplicated the “comments” plugin for my purpose, cause I want to view some things in the Admin. Because ts3admin is not a composer pack, I cant add it with php composer.phar require .... So I tried it on a other way and duplicated the vendors from Login, changed some probs and tried it again, but I did not worked. The class can not be reached in my plugin.php.
And because there is no tutorial in the docs or in the web about implementing a non composer pack, I also tried to add it like a normal class with require_once. Also failed.
Now I’m on the point, I missed something and its now 3 days left to fix the problem (and it is just this, the rest is running fine).
Maybe someone here can quickly show over my code and give me a hint to fix the problem.

TS3Admin (my fork with composer.json):

Once you figure out (I don’t know anything about Composer), let us know so I can add it to the “Learning by Example” page.

I found a solution, but I had to go another way. I reprogrammed the plugin into a GRAV plugin and added it like a normal class into the plugin. It was the only solution I found for a quick result.