Privacy Plugin


Don’t know what I’m missing to enable this plugin for certain pages.

When I installed the plugin, the site was password protected. I then downloaded the yalm file and placed it in the user\config\plugins. I set the enable option to false.

On the page I want to protect I then added (well I tried the following)

private: true
private_site: true

but all failed.

title: Research Notes
date: 09:56 08/09/2015
author: Steven Venter
    category: blog
    tag: [research]
    theme: vs 
private: true

Could someone help me to resolve this issue?


I used this yesterday and it bricked my local site - i couldn’t see how to get rid of the login despite renaming the plugin, deleting it, clearing cache/session

Did you copy the yalm file to the users directory like it says on the plugin page?

If so did you disable the plugin?

enabled: false

After I did that the site was unprotected. My problem is I wan to protect some pages.

Im just trying to make private whole site -
But i get
InvalidArgumentException thrown with message “Identifier “user” is not defined.”

What have you tried?

Did you change the seed in that yalm file? And did you generate a new hash for your user?

I must admit I did not try to login to the protected site. As soon as I saw that the site was protected I disabled it.

With Private plugin i generated new hash but it has stopped working/rendering any form. Pretty much gonna give up now

Ok just tried to protect the site and it work.

I was able to login.

Did not see a logout button??

Sorry missed this post - no i didn’t see one either but there are routes configured for it.