Porting to Google Instance from localhost Issue

I have Grav running plus my pages for a site. All runs well on my desktop.

I created an instance in google to run the site. Installed apache, installed PHP, changed the permissions and group to what I think should work. Checked the extensions in PHP and I have all the noted Grav required modules active.

I can run a test html page unrelated to the Grav site with no issues (in the root folder). I can run the PHP information display without issues.

I looked for any file in my local Grav site for “localhost” or “” or any other entry that might be local specific. Nothing that I can find. I cannot run siteaddress/admin or any other Grav page.

So… What is the drill to successfully port Grav to a Google (or any) Centos 7.x, Php, 7.2 instance?? I must be missing something.

Sounds like you are close. There’s a few things I don’t understand in your question:

What do you mean “in google”?

I could ask some questions here but I would much prefer you try rephrasing this first. Sorry, it’s not clear what you tried.


I am using Google Cloud, a compute instance (happens to be micro which is the smallest but should be able to run a php & apache site. [ https://cloud.google.com/compute/ ]

For the second point, I was looking in the code anywhere for something that might be my local specific setting (like Wordpress does).

Since playing around today and still no luck, I’m thinking it is permissions, although I just set all files and folder to 777 to test. Plus apache owns the files. I also removed all my files and uploaded only the “out of the box” beta admin version and tried that today. Still not working

I can answer some things now but probably not solve your overall problem.

The only place you will find the site’s hostname in the files is if you use environment-specific configurations. I know Wordpress references its hostname in its database and that’s so f&*% stupid. Makes it just that little bit more difficult to export/clone/rename/escalate, you know all those things website builders typically do :confused:

Did you change permissions according to the recommended settings in the Troubleshooting - Permissions section of the docs?

I’m not sure what logs Google Cloud lets you see, but I often find clues to white screens in PHP or web server logs. Is it a white screen you are seeing? You haven’t said that either.