Paginiation does not work when enabling caching

I’m using the pagination plugin for a news archive. My system.ymal looks like this:
enabled: false
method: file
driver: auto
prefix: g
clear_images_by_default: true
cli_compatibility: false
lifetime: 604800
gzip: false
allow_webserver_gzip: false

When I set cache: enabled to true the pagination does not work anymore. The url page parameter changes from :1 to :2 ect. but the content is always the content from the first page.
I’m using nginx with apc/apcu enabled.
What am I doing wrong?

1 Like

What theme are you using?

I created my own theme.

Can you try using file instead of APCu?

@fabbow: I already tried this. Unfortunately, without any change. Paging is still not working with caching enabled.

I was able to fix the issue. It is related to the “Minify Html” plugin, I’m also using. When “Minify HTML cache” is disabled paging is working again with caching enabled. Im not sure if this behavior is intended. I looks like the minification of the cache entry removes the paging information.

1 Like

Remove the original Minify HTML plugin and use the new one HTML Minifier version 1.1.2 has fixed this issue on Feb 7th, 2022, verified, works well (I had the same issue)

1 Like