No matter which Feed I chose, it directs me to Home page?


#1

Hello!

Having a problem, probably with configuration, with Feed (v1.6.2) plugin (even I don’t find it “guilty” in this case) and/or my theme - Quark Open Publishing (v1.1.5). The thing is, no matter which Feed option I chose (json, rss, atom) it directs me to Home page (/). Those buttons are placed on route (/vijesti) so etc. RSS feed should be named (/vijesti.rss). I was checking div element inside sidebar.html.twig with this buttons and I find no problems (“feed_url” seems to return “vijesti” and appending the “.rss” or “.atom” or “.json” works well). It just won’t let me go to Feed page.
Is that because page “Vijesti” is my home page and the route (…/vijesti) isn’t showing in my URL bar?

Check it out: http://siportal.diverto.hr/


#2

Hi @XizzoR, I am the author of Quark Open Publishing and I took a look at your site. Usually your feeds would be based on the slug of your blog page, for example in the OPS skeleton it is /blog.rss - is vijesti the slug of your blog page?

I am afraid my knowledge of the Feed plugin is pretty limited, have you tried just using the base Quark theme (which QOP is based on) to see if it is an issue just with QOP? Also, might it be helpful for you to refer to the Quark Open Publishing skeleton to see how that Feed config works? https://getgrav.org/downloads

Feel free to also contact me directly on the Grav Slack if you find the OPS theme is the issue https://chat.getgrav.org/


#3

Thank you for your answer @paulhibbitts

Tried to modify slug to “vijesti” but ended with no results, problem still exists.
Then I tried to make another page (same hierarchy level as “vijesti”) and set it to Home Page. That was the only modification I made - and then, Feeds worked!

It seems to be the problem when there is no explicit stating in URL for page which will be “listed” by Feed plugin. In other words, being on site “vijesti” with URL “siportal.diverto.hr” I can’t generate feeds, but when being on site “vijesti” with URL “siportal.diverto.hr/vijesti” I am able to generate feeds (etc. when clicking on RSS it would produce “siportal.diverto.hr/vijesti.rss”).
Of course, explicitly typing “siportal.diverto.hr/vijesti” in URL bar, while having “vijesti” page as my main page, will automatically redirect me to “siportal.diverto.hr”.


#4

Glad you made some progress @XizzoR! What is your system.yaml setting of the “Hide home route in URLs” setting? I wonder if that might be involved? For all of my sites using Feeds I have it set to No.


#5

Thank you so much @paulhibbitts
It wasn’t problem in “Hide home route in URLs” (I already have it set up to “No”), but it was in “Redirect default route” which was set to “Yes”. After I set it to “No”, problem was gone, feeds are working again!