Newbie question about installing Grav on Mac OS 10.12

#1

Hi,
Willing to give Grav a try I just downloaded a skeleton package, and did unzip it to what I believe is the webroot per default of my Mac (OS10.12 comes with a default apache server, right?): /Library/WebServer/Documents/

But when I try to access it with http://localhost/grav-skeleton-boxify-site I get nothing but a “This site can’t be reached”. Note that I get the same when simply hitting http://localhost

So, I assume the apache server is not running automatically. Is that right? Grav install page is not very explicit on all those aspects. Any hint is most welcome…

Cheers,
Xavier

#2

Hi,

there are some blog posts about developing on Mac that helped me a lot:
macOS 10.13 High Sierra Apache Setup: Multiple PHP Versions, Part 1
Part 2
Part 3

Please note that it might be a little different since you are using macOS 10.12, but I think it could be helpful.

#3

Thanks, I thought the post was dedicated to a peculiar issue, but it gave
me the hint I needed. A simple
sudo apachectl start
solved part of my issue since no I have a localhost server running…

Now it says that
You don't have permission to access /grav-skeleton-boxify-site/ on this server.
But this is clearly solvable. Thanks for the reference!

Xavier

#4

Those blog post address all issues with permissions becuase it prompts you to run the web server with your ‘user’ account rather than the default user.

#5

I have exactly the same message under Windows and Xampp while using ALIASES : it’s a problem of HTACCESS and of tweaking it to allow a good operation with aliases (if you configured one).

I solved it by adding a line :
Options +FollowSymlinks

In every bundle projects that I used, there is always the problem of addind this line, wich is completly ignored by authors of documentations.

#6

I know that cleaning the webrowser cache helps in simple situations. For more complicated situations (like yours I suppose) read article about 8 solutions to fix the problem this site can’t be reached