Need Help with "SlideMe" slider

I am having problems getting the “SlideMe” slider to autoplay for my site using the Deliver theme. I have located the .js file and made the appropriate changes and it “should” work, but for some reason it is not. Any ideas would be very appreciated.

If You have pipeline enabled for the JS you will need to clear the cache to get the JS to recompress.

I have no idea what pipeline is or how to disable it.

If you don’t know what it is, it’s unlikely you have it enabled. More information in the docs btw.

Was just an idea anyway. Other than that, you should view the source of the JS in the browser, do you see your changes?

I modified the showcase.html.twig file to get the showcase to autoslide in the deliver theme. Here is what mine looks like:


This works great if you have just the one showcase on your site, or if you want all showcases to behave the same.

In deliver configuration file (site.yaml), you have all header options described:

  arrows: 'true'                            # Create Next and previous button
  autoslide: 'false'                        # Auto slideshow mode
  autoslideHoverStop: 'false'               # Pause auto slideshow mode on mouseover
  interval: '2000'                          # The interval between each slide (Interval in millisecond)
  loop: 'false'                             # Infinite slideshow             
  transition : zoom                         # Set the animation kind (fade/slide/page/zoom)
  itemsForSlide: '0'                        # Wrap each 'n' item
  touch: 'true'                             # Set a native slide for touch device
  swipe : 'true'                            # Enable swipe for touch device

Thanks, Karol. I had no idea that I would need to go into the .yaml file. Geez, I wasted so much time on this. I assumed that I simply had to make my changes in the plugin’s .js file.

Yeah… I was trying to make that theme as much configurable as possible… Next time i will make info about configuration file a little bit more visible.