I tried to create a multisite INTO my existing site, so it sports a layout like this:

grav default-site and root is in ‘

  • Reason is (more or less), both sub-sites use different themes than the base site

Default files are located in ‘’ and everything works fine (including admin-plugin, etc…)

I created a ‘multi’ subdirectory (containing all required grav files) in

  • and ‘more’ one to

I also created/copied the required setup.php for subdirectories (from
I added the required plugins manually (as I couldn’t find out how to install these using gpm)

Now, navigation, etc… works (sub-site plugins are not loaded), but I can’t get the admin-plugin to work with these sub-sites:

  • If I access admin on my main site ‘’ everything is fine, but I don’t see the sub-sites from there.
  • If I try to access ‘’ I’m getting a ‘Server Error’ (‘0 - One of the required plugins is missing or not enabled’)

Is the way I tried that correct or do I need setup my site using subfolders only and then redirect the desired ‘main’ site using a redirect from the grav-admin?

Any info appreciated


BTW: I tried installing ‘’ according to the documentation there and get the same error…

[2016-05-15 20:31:49] grav.CRITICAL: One of the required plugins is missing or not enabled - Trace: #0 /Users/andy/Sites/grav/user/plugins/admin/admin.php(258): Grav\Plugin\AdminPlugin->initializeAdmin() #1 [internal function]: Grav\Plugin\AdminPlugin->onPluginsInitialized(Object(RocketTheme\Toolb ox\Event\Event), 'onPluginsInitia...', Object(RocketTheme\Toolbox\Event\EventDispatcher)) #2 /Users/andy/Sites/grav/vendor/symfony/event-dispatcher/EventDispatcher .php(181): call_user_func(Array, Object(RocketTheme\Toolbox\Event\Event), 'onPluginsInitia...', Object(RocketTheme\Toolbox\Event\EventDispatcher)) #3 /Users/andy/Sites/grav/vendor/symfony/event-dispatcher/EventDispatcher .php(46): Symfony\Component\EventDispatcher\EventDispatcher->doDispatch(Array, 'onPluginsInitia...', Object(RocketTheme\Toolbox\Event\Event)) #4 /Users/andy/Sites/grav/vendor/rockettheme/toolbox/Event/src/EventDispa tcher.php(23): Symfony\Component\EventDispatcher\EventDispatcher->dispatch('onPlugins Initia...', Object(RocketTheme\Toolbox\Event\Event)) #5 /Users/andy/Sites/grav/system/src/Grav/Common/Grav.php(449): RocketTheme\Toolbox\Event\EventDispatcher->dispatch('onPluginsInitia.. .', NULL) #6 /Users/andy/Sites/grav/system/src/Grav/Common/Grav.php(259): Grav\Common\Grav->fireEvent('onPluginsInitia...') #7 /Users/andy/Sites/grav/index.php(38): Grav\Common\Grav->process() #8 {main} [] []

It seems I can’t edit my post here, so to clarify the ‘BTW’ above:
I installed grav-learn to a clean and local grav-installation on my dev-machine, but that didn’t work…

Well - without further detailed investigation it had something to do with the included ‘learn3’ child-theme. After removing that the problem disappeared.
Maybe you want to check your github repository.

It probably is something related to incompatibilities with inherited themes with multisite. This is something we’ll have to investigate further and things start getting kinda complicated when you use multisite logic.

Thanks for the heads up.