Language mixed in plugins fullcalendar and Archive


I’m running, happily using grav. It’s a german site, so it should use german locale etc., which is working fine on the main site.

But with the Archive and the fullcalendar plugin, I get a mixture of german/english translations/time and date formats. For example: in the Archive-Sidebar I get the correct german headline “Archiv”, but the month-names are displayed in english. With the fullcalendar, I get “today” instead of “heute” an the dates in the calendar are using pm/am-notation, while something like “Heute sind keine Termine geplant.” ist displayed correctly.

What did I mess up? Let me know, which configurations should be shared,

Any hints appreciated.

Regards Hanns

hey Hanns,
it looks like the fullcalendar Plugin does not recognise your site’s language settings, which should be ‘de’ - please check.
otherwise, you can override this in any case with

lang: de

in the frontmatter of your calendar page.
Werner (the fullcalendar developer)

1 Like

Hi, Werner,

thanks for Your reply.

There was already

language: de

set. changing it to the suggested “lang: de” didn’t change anything.

I also find:

root@freebsd:/usr/local/www/apache24/data/brueckenkopf-hanau# grep -r “language: de” *
user/pages/06.termine/ de
user/pages/04.aktuelles/drum-talk-mit-curt-cress/ de
user/pages/04.aktuelles/ language: de
user/accounts/admin.yaml:language: de
root@freebsd:/usr/local/www/apache24/data/brueckenkopf-hanau# grep -r “lang: de” *
user/pages/06.termine/ de
user/ de
user/config/site.yaml:default_lang: de
user/config/system.yaml: default_lang: de
user/config/system.yaml~: default_lang: de

Any idea?

Thx in advance


ok, settings seem to fit, however, when I look into the source of your calendar page, I cannot find this entry:

<div id="cfgLocale" style="display:none;">de</div>

which should have been added by the page template, based on your settings.
are you sure your calendar page uses the correct template calendar.html.twig from the plugin ?
the relevant part of the template is this:

{% set lang = grav.language.getLanguage   %}
{% if page.header.lang|length > 0   %}
	{% set lang = page.header.lang    %}
{% endif %}
<div id='cfgLocale' style='display:none;'>{{ lang }}</div>

Hi, Werner,

the admin-interface claims, that the page is using a template called “Calendar”. Where can I check, if this is correct?

Thanks Hanns


Obviously, it was conflicting with the events-plugin, which i had installed earlier (and forgot about ist). At a first glance, things are looking good.

Thx for Your Help, Werner, I really appreciate that.

Regards Hanns

ok, fine :smiley: - I’ve been out of ideas yet after your post from 14:13.