Issues after publishing Grav with Gantry and my own Theme

Hey guys,

i’ve some troubles with Grav. On a local virtual machine, i’ve created a new fresh installation of the Grantry 5 “Helium” Skeleton for Grav and developed my own Theme. On my local machine evrything is working fine. I’ve created my own git repsoitory which automatically release my local changes to my live server, and ignores the cache, tmp and log folder.

But on my live server i receive a lot of issues.

The first issue is:

“E_WARNING - Class ‘Grav\Plugin\Form\Form’ not found”

After reinstalling the Form Plugin with the Grav CLI GPM, I get the message that the “Parent Theme” can not be found.

As I said, everything runs fine on my local virtual machine. Unfortunately, after I commit and push everything to my git repository and the data is published on my live server, it does not work anymore. The same problem I have when I load the data manually through a zip archive on my live server. I’ve attached my Grav Logfile.

I hope somebody can help me.


Your vendors probably get gitignored , if not them, it’ll be the theme that gets ignored I think, if you have access to your site through ftp / ssh, doublecheck that all the files are there :slight_smile: I’m sure there is a difference. I do find it strange that a zip wouldn’t work? Yet again, if you have ssh access to your server , do a ‘php bin/gpm index’ command to check what themes & plugins are registered as installed

hey RobLui,

sorry that i answer so late. I solved the issue and it was not Grav, but the virtual machine i use. The Problem is, that my virtual machine is managed by Vagrant and Virtual Box. The root folder where Grav is running in, is a shared folder on Virtual Box and it can not differentiate between upper and lower case.

After setting the correct Theme name in lower case spelling, it works fine on both systems.


Hello everybody,

maybe I have found the problem myself and solved. Before I developed my own theme, I renamed the existing “Helium Theme” at the beginning. I probably dont have set the same Name in “themeName/gantry/theme.yaml” at the Line “theme: parent:”, like the folder Name of my theme.

As an an example:

My folder is called “mytheme” and in the file: “mytheme / gantry / theme.yaml” is “theme: parent: myTheme”.

The different spelling of the name probably led to the problem. Me wonder, however, that it runs locally on my virtual machine, but not on my live server?

How can that be?


to make a very late reply to your question: different servers ignore/don’t ignore uppercase / lowercase spelling, and when on localhost (for me this is as an example) I can make an uppercase/lowercase mistake too, but as soon that the deployment to live comes in to hand, the live version stops working because of it. Hope this clears your mind up a bit if you’d read this :wink: @Pixelpaule