Incorrect PHP Version


#1

I’m trying to make a new theme using the theme-tutorial https://learn.getgrav.org/themes/theme-tutorial. When I enter command “bin/plugin devtools new-theme”, I get an error “You are running PHP 5.4.16, but Grav needs at least PHP 5.6.4 to run.”

I’ve checked the version using php -v and it’s saying “PHP 5.4.16 (cli) (built: Oct 30 2018 05:43:23)”

When I log into my Plesk panel, the hosting is apparently PHP version: 5.6.39. I’ve tried changing it to PHP version 7.0.33, waited 30 minutes for the changes to take place, yet I still get the exact same error messages.

Any advise would be greatful


#2

I would suggest contacting your hosting company to find out what the problem is - this is an issue with them and not with Grav.