Html code gets wrapped in `<p>` tags


I’m trying to add some HTML into the body of the .md file in a blog post, but the html always appears literally (tags and all, like it was preformatted) on the page. Inspection revealed it gets wrapped into <p> blocks, like very other paragraph.

E.g, this:

Blablabla blablabla
Some html content

where “tag” is a placeholder for any generic html tag, it becomes

<p>Blablabla blablabla</p>
<p><tag>Some html content</tag></p>

AFAIK it’s supposed to work, but it just doesn’t. Markdown extra is enabled.

Any ideas?

Got it sorted. For some reason “escape markup” was also enabled. Still confused why, is this supposed to be the default behaviour? Because all documentation talks about including HTML like the norm?