Hide Home in navigation menu

I want to hide Home from navigation, and found this old issue which got me on track: Hide `Home` from navigation.

I managed to hide it by adding {% if not page.home %} in navigation.html.twig like this:

{% if not page.home %}
    <li class="{{ current_page }}">
        <a href="{{ page.url }}">
            {% if page.header.icon %}<i class="fa fa-{{ page.header.icon }}"></i>{% endif %}
            {{ page.menu }}
        </a>
    </li>
{% endif %}

This removes the “Home” link from all pages.

I still wonder where to add visibility: false as an alternative solution … modular.md for 01.home is set to onpage_menu: false, but it doesn’t seem to have any effect.

Hi @gravus, to use the visibility option you would add this setting to the page frontmatter of the Markdown page which is your homepage. If you are using the Admin Panel visible is usually a setting on a tab such as ‘Options’ when editing a page.

For example, let’s say your home page was called Blog, and the Markdown file was called ‘blog.md’, then the frontmatter would be:

visible: false
2 Likes

Hey @paulhibbitts, that worked perfectly, thanks for sharing! To others, here is the setting: ‘Pages’ > ‘Home’ > ‘Advanced’ > set ‘Visible’ to ‘Disabled’ and click ‘Save’. Like @paulhibbitts write, this will add visible: false to the settings file for the page.

1 Like