Heroku 403 Error

apache
#1

I am attempting to run the my application on heroku. I have followed the steps outlined in the documentation precisely, deploying only the the grav+admin code without modification. When I deploy, I get a 403 error, reading

Forbidden
You don’t have permission to access / on this server.”

I suspect this may be related to some configuration of the htaccess file, but do not know what requires update.

I found the following message in the log file:
“Cannot serve directory /app/: No matching DirectoryIndex (index.php,index.html,index.htm) found, and server-generated directory index forbidden by Options directive”

I assumed this related to an issue with the RewriteBase configuration, but I confirmed that the directory name matches the directory in which those index files are stored.

Any guidance is appreciated.

#2

I think you’ll just have to set your base_directory in your host to app/
Have you tried to put in an absolute url from within the server, e.d. like: /var/www/app/… ?

Not sure on this, but that’s my main guess