Grav + Vagrant (Scotch Box) Issues

Hi all.

I’m attempting to run Grav in a Scotch Box Vagrant environment on Ubuntu 14.04. I’ve tried several different versions of the installation process (copy manually into root, git clone), and in none of the cases has the CLI or GPM worked. I’m not sure if I’m installing it incorrectly or what…but I’m just getting errors. It’s as if the CLI is not actually installed or recognized on the system.


php -v


vagrant@scotchbox:~$ php -v
PHP (cli) 
Copyright (c) 1997-2015 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2015 Zend Technologies
    with Zend OPcache v7.0.6-dev, Copyright (c) 1999-2015, by Zend Technologies

On a fresh manual install, I copy all of the files over into the root directory of the server, then go to the site and create the admin user (as prescribed). After that, I pull up the command line/terminal and move into the root directory.

vagrant@scotchbox:/var/www/public$ bin/gpm selfupgrade -f
-bash: bin/gpm: Permission denied

Is anyone having any success with Scotch Box and Vagrant? I tried the Puppet script provided on the Grav blog, but it’s a year old and threw a bunch of errors on install.

try doing a chmod +x bin/* to ensure those commands are executable.

Thanks for the suggestion…sadly it didn’t work.

I’m not sure if it will help, but I’m going to try to find another pre-provisioned vagrant box to try this on.

For anyone that cares…Scotch Box just doesn’t work “out of the box” with Grav as far as I can tell. I spun up a Puphpet Ubuntu Vagrant box with the correct dependencies and everything seems to be working at this point.

Did you SSH into the box to run the command? I had a similar issue with Laravel and I had to SSH into the vagrant to run the command.

Yep. I SSH’ed into the box to run the command. I love Vagrant as I can leave my host Ubuntu install completely agnostic to all of the dev environment with the exception of the browser, editor, and terminal. All of the “commands” and heavy lifting get done inside the Vagrant box.

Do you get any specific error message when you run the command?

A variety. I’ll try to pull up a Scotch Box again and get the specifics.