Grav v 1.6.6 crashing

#1

After upgrading from 1.6.5 to 1.6.6 Grav throws a twig error immediately :

An exception has been thrown during the rendering of a template ("Property 'inlinejs_pipeline_before_excludes' does not exist in the object!").

Theme Bones 0.5.2
PHP 7.2.16
admin 1.9.2

URL to see the error http://www.greenmanpress-music.co.uk/

What should I do?

#2

To solve temporarily you can add this line

protected $inlinejs_pipeline_before_excludes;

to the file

/system/src/Grav/Common/Assets.php

on line 53.

Obviously, with every Grav update, you would miss it!

Then open a ticket at https://github.com/getgrav/grav/issues

#3

Thanks @iusvar, will do.

#4

It is the theme, not Grav, throwing the error. It has been reported: https://github.com/smartgravity/grav-theme-bones/issues/41.

#5

I’m sorry I misled the people involved :face_with_hand_over_mouth:

#6

Don’t worry, it’s all been explained - and dine of the problem was my

73 Huntington Road
YO31 8RL
07947 002 581
01904 673675

#7

… some of the problem was my fault YAML

73 Huntington Road
YO31 8RL
07947 002 581
01904 673675