Grav show blank page

I can’t remember what I have modified in config, but whatever from sites show nothing, blank page always.

Logs show the following lines:


2019/07/28 19:26:10 [error] 30994#30994: *6 FastCGI sent in stderr: “PHP message: PHP Fatal error: Uncaught RuntimeException: Failed to save file /var/www/grav-admin/cache/compiled/blueprints/master-linux.bersol.info.php in /var/www/grav-admin/vendor/rockettheme/toolbox/File/src/File.php:351
Stack trace:
#0 /var/www/grav-admin/vendor/rockettheme/toolbox/File/src/PhpFile.php(31): RocketTheme\Toolbox\File\File->save(Array)
#1 /var/www/grav-admin/system/src/Grav/Common/Config/CompiledBase.php(252): RocketTheme\Toolbox\File\PhpFile->save(Array)
#2 /var/www/grav-admin/system/src/Grav/Common/Config/CompiledBase.php(117): Grav\Common\Config\CompiledBase->saveCompiledFile(’/var/www …’)
#3 /var/www/grav-admin/system/src/Grav/Common/Service/ConfigServiceProvider.php(77): Grav\Common\Config\CompiledBase->load()
#4 /var/www/grav-admin/system/src/Grav/Common/Service/ConfigServiceProvider.php(36): Grav\Common\Service\ConfigServiceProvider::blueprints(Object(Grav\Common\Grav))
#5 /var/www/grav-admin/vendor/pimple/pi” while reading response header from upstream, client: 85.87.102.174, server: linux.bersol.info, request: “GET / HTTP/1.1”, upstream: “fastcgi://unix:/var/run/php/php7.2-fpm.sock:”, host: “linux.bersol.info:444”

Can you help me?
Regards,

I have Website down.
How can I recover it?
I don’t care if I lose configs…

I forgot to say I change config with grav-admin plugin…

SOLVED:
I don’t know why (perhaps some plugin installation), but “var/www/grav-admin/cache/compiled” directories had root owners:

drwxr-xr-x 2 root root 4096 jul 28 16:12 blueprints/
drwxr-xr-x 2 root root 4096 jul 28 16:12 config/
drwxr-xr-x 2 www-data www-data 20480 jul 28 18:54 files/
drwxr-xr-x 2 root root 4096 jul 28 16:12 languages/

I’ve changed to “www-data” and it works again.

Solved, only temporary.

I’m getting this problem several times, I don’t know why, some admin change looks do the change, perhaps, but I have to change owner permissions manually many times.

I think it could an admin bug, “clear cache” option perhaps, but I’m not sure.
Regards,

Have you tried this?

Permissions problem almost certainly. For the love of all that’s holy, use a test server so this won’t happen to your live sites.

I know is a permissions problem (I posted this at 28th july).
But the problem is why admin panel change owner of “./cache/compiled” directories to ROOT??