File Upload form - no file loaded

Running basic Quark theme on clean skeleton demo; hosted on apache
Added user/pages/02.upload; file form.md

title: Upload

form:
    name: upload
    fields:
      myfile:
        type: file
        label: Uploads
        destination: '/user/data/upload'
        multiple: true
        autofocus: false
        accept:
          - image/* 
    buttons:
      - type: submit
        value: Submit
    process:
      reset: true
      message: Thanks!

Appears to work fine, but no files loaded, have tried a few destinations. no errors in log. Loading small jpg file - validates ok in drag’n’drop box
There seem to be a few errors like this, but no clear resolution - some say ‘fixed’

not modular - simple one page form. Note I have a contact form working fine
depending on when you look this may be available at www.jzedward.com/upload
tia - jzedward

@jzedward,

See Grav frontend file uploading not working properly · Issue #550 · getgrav/grav-plugin-form · GitHub

Had a similar issue, was trying for hours. It worked for me when I removed “reset: true”.
With “reset: true” the file was not saved at its destination.

By the way, Grav will throw trying to save to your absolute path. Try making it relative user/data/upload.

1 Like

brilliant! removed reset:true and changed from @self
that will teach me to cut’n’paste code I don’t know…

@jzedward, Did some debugging and created a new issue.

A better workaround would be to add upload: true to the process array. Removing ‘reset’ might cause some unwanted side effects in the UI after submitting the form.

process:
  upload: true
  reset: true
  message: Thanks!
1 Like