Error on custom Shortcode path

I’m using the Hotdoy Theme which comes with a number of custom Shortcodes so I created a custom path to install them as per the suggestion in Shortcodes-Core plugin.


As soon as I save the plugin I immediately get the following error:

Server Error

Sorry, something went terribly wrong!

### E_COMPILE_ERROR - Grav\Plugin\ShortcodeCore\ShortcodeManager::registerShortcode(): Failed opening required '/var/www/grav/user/custom/shortcodes/@eaDir' (include_path='.:/usr/share/php')

##### For further details please review your  `logs/`  folder, or enable displaying of errors in your system configuration.

Removing the path from shortcodes-core.yaml fixes the issue but added it again bring the problem back.

This is the error within the logs:

Grav\Plugin\ShortcodeCore\ShortcodeManager::registerShortcode(): Failed opening required '/var/www/grav/user/custom/shortcodes/@eaDir' (include_path='.:/usr/share/php')

I’m running Grav via docker ( on my Synology DS918+ and there is no @eaDir directory in the location.

I am using the latest shortcodes-core plugin along with the latest install of Grav (with admin). Any help would be graceful.

Hidden @eadir folders are created, when AFP is enabled on your NAS. Unfortunately the plugin tries to process these folders.

The only way I see is to disable AFP or not to access the shortcuts folder via AFP, once you cleared it. Use SMB instead. In the moment you access via AFP, the NAS recreates the @eadir.

Thanks for the tip, are you aware of anyway to exclude @eadir folders from within Grav so they are not processed?

The strange thing is I can’t see these folders even with invisibles shown.

I think they are only visible, when you connect via SSH and do a
ls -la
in that folder.
There is no generic way to exclude them neither on the NAS nor on Grav’s side. If you cannot switch off AFP, then the only way is to rewrite the plugin code.

1 Like

Thanks for your help, much appreciated.