Error 500 after few click

I everyone; I get ride of my WordPress for GravCMS
My config still the same CentOS7, NGINX, PHP7
I’m currently experiencing Error 500 which I could correct by bin/grav clear
So it’s probably a Misconfiguration Cache somewhere between my NGINX and my system.yaml.

I found and try the NGINX configuration proposed by GravCMS without big change.
But I also have a bunch of config into my nginx.conf like :

[...]
http {
    # Main settings
    sendfile                        on;
    tcp_nopush                      on;
    tcp_nodelay                     on;
    client_header_timeout           1m;
    client_body_timeout             1m;
    client_header_buffer_size       2k;
    client_body_buffer_size         256k;
    client_max_body_size            256m; 
    large_client_header_buffers     4   8k;
    send_timeout                    30;
    keepalive_timeout               60 60;
    reset_timedout_connection       on;
    server_tokens                   off;
    server_name_in_redirect         off;
    server_names_hash_max_size      512;
    server_names_hash_bucket_size   512;
[...]
    # Compression
    gzip                on;
    gzip_comp_level     9;
    gzip_min_length     512;
    gzip_buffers        8 64k;
    gzip_types          text/plain text/css text/javascript text/js text/xml application/json application/javascript application/x-javascript application/xml application/xml+rss application/x-font-ttf image/svg+xml font/opentype;
    gzip_proxied        any;
    gzip_disable        "MSIE [1-6]\.";
[...]
    # Proxy settings
    proxy_redirect      off;
    proxy_set_header    Host            $host;
    proxy_set_header    X-Real-IP       $remote_addr;
    proxy_set_header    X-Forwarded-For $proxy_add_x_forwarded_for;
    proxy_pass_header   Set-Cookie;
    proxy_connect_timeout   90;
    proxy_send_timeout  90;
    proxy_read_timeout  90;
    proxy_buffers       32 4k;
[...]
    ssl_session_cache   shared:SSL:10m;
    ssl_session_timeout 180m;
[...]
    # Cache settings
    proxy_cache_path /var/cache/nginx levels=2 keys_zone=cache:10m inactive=60m max_size=1024m;
    proxy_cache_key "$host$request_uri $cookie_user";
    proxy_temp_path  /var/cache/nginx/temp;
    proxy_ignore_headers Expires Cache-Control;
    proxy_cache_use_stale error timeout invalid_header http_502;
    proxy_cache_valid any 1d;

    # Cache bypass
    map $http_cookie $no_cache {
        default 0;
        ~SESS 1;
        ~wordpress_logged_in 1;
    }

    # File cache settings
    open_file_cache          max=10000 inactive=30s;
    open_file_cache_valid    60s;
    open_file_cache_min_uses 2;

So Any kind, even it’s like obvious, help, though
would be appreciate.

Regards!

Jonathan

Might be permissions? Covered in https://learn.getgrav.org/troubleshooting/internal-server-error and https://learn.getgrav.org/troubleshooting/permissions

Nice try but I still have a Error 500 after few refresh! :frowning:
I don’t know if it’s normal but, even with the 500 Error the backend (admin) still available.

So far so good; I reinstall GravCMS via the ZIP and everything sound good.

My buggy installation was through Composer which I did composer update after and install few module was suggest by it […]