Error 500 (Nginx)

Hi all,
I installed grav with composer and ser up Nginx to point to the root folder, but when i go to the url ( i get a 500 ERROR.
I created a php test file and works well (

Someone can help me?

Not seeing an error, just a blank Nginx page.

I’m having the same problem (internal error 500). How did you get your site to work?
I’m running my site on a shared hosting account with cpanel. I have uploaded a php info file and it works (showing php 5.6.18). I had to upgrade to 5.6 because my host’s 5.5.3 fails the requirements.

The next step in grav’s troubleshooting documentation reads:

Register Globals Issue
Some people who have recently upgraded to PHP 5.5 from version 5.4 or 5.3, may still have some out of date settings in their php.ini file. One item that can cause a 500 Internal Server Error is the register_globals setting. Simply remove or comment out the line:

register_global = On

Sorry, as a newbie coming from wordpress I’m unfamiliar with command lines.
Where do I find the php.ini config file and how do I modify it in a text editor to achieve this? Thanks.

The error 500 is a general server error, the cause may be very different. In this case you are using Apache, not Nginx, and it’s all different.

The php.ini location depends on the hosting provider. Check their documentation or open a ticket so you’ll know the exact location.

Also, check the server error logs. They might show a message that can help debugging the problem.