Custom header logo not showing when using FQDN as URL

I have set up a new Grav site, using the default Quark theme. I have set a custom header logo under the theme settings. When I access the site using the IP address as the URL, my custom header logo shows at the top. If I use the FQDN of the server as the URL, I see the default Grav header logo. I have cleared the cache in Grav, rebooted the server, cleared the browser cache on the PC, and I’m still see the same behavior from multiple PCs. Does anyone know how to resolve this?

Thank you

@Jason, Grav tries to find theme/plugin config files in three locations:

  1. /user/env/<domain>/config/…
  2. /user/config/…
  3. /user/<themes-or-plugins>/…

It might be that your changes have been saved in location 1, in the folder for domain “X”. When switching domains Grav tries to find the config in location 1, using the folder for the current domain “Y”, but won’t find it. It will then fallback to location 2, and if that doesn’t exist, to the config in the themes/plugins folder.

So, that might be the reason why your custom header logo is not showing when switching domains.

See issue Theme settings set in Admin saved under user/env/…/config/themes instead of user/config/themes

Thank you, you helped me resolve the issue!

I was logging into the admin site with the IP address as the URL. When I logged in to the admin site using the FQDN as the URL, I found that my logos were not showing up. I uploaded the logos again, and now I see the correct logo when using the FQDN or the IP.

Thanks again!