Crikey when uploading to webserver

apache

#1

Hello!

Just to be specific, I have started out my new grav project from https://github.com/hibbitts-design/grav-skeleton-open-publishing-space.

I have an older version of grav on the same server with same file permissions that still works without any problems.

Offline with xampp everything worked well, but now when I uploaded it to a webserver (CentOS 7, Apache/2.4.6, PHP 5.6.30) it won’t load in as it says:

Whoops \ Exception \ ErrorException (E_WARNING)
include(/var/www/html/sites/lelki/vendor/composer/…/twig/twig/lib/Twig/Cache/Filesystem.php): failed to open stream: No such file or directory

from /var/www/html/sites/lelki/vendor/composer/ClassLoader.php

“include(/var/www/html/sites/lelki/vendor/composer/…/twig/twig/lib/Twig/Cache/Filesystem.php): failed to open stream: No such file or directory”

The only thing seems different is that git has changed the line endings to windows style CRLF. Tried to convert it back and still having this problem. Permissions seems to be just right (files 0644 and directories 0755, also tried with everything being 777). Cache directory gets created.

This error can be found now online at http://istenieroforras.igehirdetes.ma/

What to look after?


#4

This problem was due to a copying problem related to git I believe. Something goes wrong when using git clone instead of actually just uploading the folder/zip.