Copy of the grav folder

Hi guys, I need your help (again :wink:).

I would like to have an exact copy of the grav folder (for development purposes). And I want this copy to run, i. e. I want to see the pages via http. (I have tried the obvious - copying the grav folder to another one and this copy does not function.)

Is there a clever way of doing so?

I have tried the sandbox utility (as described in documentation) and the result is not usable. The folder with pages was transferred OK but there are no plugins nor theme installed in the sandboxed copy. Furthermore, I am experiencing problems when trying to install them, because I am unable to copy bin folder from the original folder to the new one

[sue@lia grav]$ cp -r bin/ …/devel/
cp: ‘bin/’ and ‘…/devel/bin’ are the same file

When trying to install the Deliver theme in my devel folder using

[sue@lia grav] bin/gpm install deliver

I get

PHP Fatal error: Uncaught RuntimeException: Failed to save file /var/www//lia/devil/cache/compiled/blueprints/master-localhost.php in /var/www/lia/grav/vendor/rockettheme/toolbox/File/src/File.php:351

Which tells me that the installation process is trying to write in the original (lia) folder instead of the new one (devel).

Any suggestions how to achieve two running copies of grav?
Thanks.

Hello,

Maybe you could do two installations, on separate folders :
mysite/grav1 and mysite/grav2

Once grav1 is as you want, rename mysite/grav2/user to mysite/grav2/user_ and copy mysite/grav1/user to mysite/grav2/

Hi, I appreciate you trying to help. Will you please tell me what advantage renaming

mysite/grav2/user to mysite/grav2/user_

has over just rewriting mysite/grav2/user with
mysite/grav1/user?

Just wondering…

(I am beginning to think that my biggest enemy is the Enterprise Linux which I am supposed to use. The Ubuntu machine I used previously was much friendlier, i. e. I was able to run multiple gravs with no trouble.)

Hi all,

I have discovered - after three quite painful days - that the root of my problem is the root himself, respectively missing entry from virtual.conf. With this issue fixed, copied grav folders work just fine (I am happily running three exact copies at the moment), no need to install everything again.