Cache Initialization


I’m playing with grav for the first time. Attempted to port an existing blog with 2898 entries, generating files, placing them in grav/user/pages/ folders, using the Blog Site skeleton on my MacBook Air. The front page loads, but an individual page gives an error:

                Maximum execution time of 30 seconds exceeded

Seems to hang on this code:

                // compute score of content to content matches
                if ($config['content_match']['process']) {
                    similar_text($page->content(), $item->content(), $score);
                    $content_matches[$item->path()] = intval($score);

Is there a cache initialization task I need to do first?


We’ve only really tested Grav up to about a 1000 pages, so your in a bit of uncharted waters with your blog size. The first thing I would recommend is to turn of the page checking to ensure that every page is not checked for modifications on every load. It will mean you will have to manually clear the cache if there is a new page added or modification made. You can do this by editing your user/config/system.yaml file and changing the page check method:

    method: none

That should help things out. After that, if it still hangs, can you please provide the FIle name, and line number of the code you have pasted above? And we can look a little deeper.


Thanks for the suggestion. I tried both of these settings (pages: check: method: and cache: check: method: - which was there before) and still got the error.


Maybe turn off the related pages plugin for now. You can just uninstall it with gpm (you can install it again later if needed).

bin/gpm uninstall relatedpages

Can you also paste your current system.yaml file between triple ticks (or put up a gist)