/bin/ is not executable

I’ve finally managed with the hosting, but now I get these error on install:

/bin/plugin is not executable
/bin/composer.phar is not executable
/bin/grav is not executable
/bin/gpm is not executable

I’ve set /bin directory chmod to 755, which is executable, but I still get these errors. I don’t have access to ssh. Can you please advice?

You don’t need to set the folder permissions to executable, but the single files contained in that folder.

Normally there is no need to set file permissions. Not sure what’s going on but this is definitely not caused by Grav. It’s either your hosting configuration or the way you are installing Grav.

I’ve tried third hosting, which allowed to change permissions, but the latest error :

PHP OpenSSL (Secure Sockets Library) is not installed

Can this check be disabled?

According to the Grav docs, openssl is required. Can you get to a command line(terminal) and type this : php -m and Hit enter key. Look at the result and check for openssl

In case you don’t have access to the command line, usually in a shared hosting environment, you can check support for OpenSSL by using the phpinfo command. Simply create a new file named phpinfo.phpwith this content:


Upload the file to your web server and run it, for example point your browser at: http://<your_domain>/phpinfo.php.

The command will show you the current PHP configuration. Now look for a section about OpenSSL like this: Screenshot If such a section is missing your hosting environment lack support for OpenSSL. In that case contact your provider or consider a switch to another hosting provider.

FWIW, i added this check in the problems plugin because so many people were stubling over the fact they could not call the CLI commands properly. However, I had no clue the reverse would be such an obstacle, and people would have so much trouble understanding the error message, and how to fix it.

For the sake of simplicity i’ve removed this check for the next update of the plugin.

I got the same error message even when I got a green check on PHP OpenSSL (Secure Sockets Library) is installed

Manually setting these files to executable fixed the problem for me.

The executable check has nothing to do with OpenSSL.

I just had the same issue with a fresh install on a new shared hosting service. It turned out that “bin” was a reserved subdomain/folder name, and thus the hosting service couldn’t run the files in the bin folder.