Taxonomy list returns nothing

I had some issues with a (mostly) working website, so started with a new Grav-quark. I added plugins to make sidebar as it was i.e. sidebar, simplesearch, random, taxonomylist, archives - all work nicely except taxonomy list.html.twig finds an empty taxlist and displays only the heading.

My blog page is “blog”.
I am using the default category blog and tag as desired in system site.yaml

taxonomies: [category,tag]

user/config/plugins/taxonomylist/yaml is as follows

enabled: true
route: /blog

A sample page in user/pages/blog is

title: 'Cuba 2016'
    category: blog
    tag: holiday
visible: false
date: '2016-02-25'
leadimage: cuba_group.jpg

sidebar template has

{% include 'partials/taxonomylist.html.twig' with  
     {'base_url':new_base_url, 'taxonomy':'tag'} %}

new_base_url is “/clean/blog” where “clean” is the project in htdocs.

I cannot begin to understand the first two lines of sidebar.html that derive new_base_url as used in taxonomylist. Should it maybe be “/clean/user/blog”? or ?

I must be missing something obvious and welcome any suggestions.


@normawhite, Haven’t been ably to replicate your issue…

Don’t worry about that, the value is only used to set the url of each category. It has no impact on the display of categories in the list.


  • Download a copy of skeleton of ‘Blog Site’:
  • Copy folder ‘grav-skeleton-blog-site’ from zip below ‘/htdocs’
  • Without making any changes, browse to ‘localhost/grav-skeleton-blog-site’. It should display a working list of categories in the sidebar.
  • If it does…
    • Replace the ‘/pages’ folder from the skeleton site with the ‘/pages’ folder from your site.
  • If that still shows a list of categories…
    • make a change you need for your site,
    • clear the cache
    • check the taxonomy list
    • make another change

NB. I’ve formatted you post. Please use triple back-ticks (```) when showing code.

Thank you - I was looking for that blog skeleton yesterday and missed it.

I did what you suggested, changed the name of my blog page to actually blog and all is well with the taxonomy.

But the archives are empty both with Gravatastic Blog and with my pages. I checked that the archive plugin was installed and enabled.
I put a couple of prints in archives.html.twig and got new_base_url /blog archives_data — so the code is exercised.
Why might archives_data be empty?

I was working on the blog because some time ago (I think December), I was trying to get archive plus to work and removed and put back one or both of the two plugins and my archives vanished. I never found out why and never got them back. Is this related to the missing archives in grabatastic blog?

Now I have a version with working popular tags and a version with working archives:)

@normawhite, To clarify: In your fresh copy of the ‘Site Blog’ skeleton, without making any changes, ‘Popular Tags’ is showing tags, but ‘Archives’ is empty?

It is even empty in the skeleton Everything else there is as it should be.

I traced through the code to make sure that the function displaying the archives_data is present and exercised (as it is in mine too). I could find no explanation for the missing archives, except that archives_data is empty and have no idea why that might be. Is it possible that an update caused it to begin failing, possibly in dec?


It is even empty in the skeleton

You are right, a fresh download of the skeleton shows an empty Archive…

There has been a bug reported on Archives about this issue recently.

I recall having run $ bin/gpm update on my downloaded skeleton a couple of weeks ago. So I didn’t notice the issue on my skeleton.

Run $ bin/gpm update (or use Admin) on your site to fix Archives.

I have updated and changed nothing and archives produces nothing. The terminal output below suggests that I have the latest version of everything fro gravatastic blog.

normawhite@Normas-iMac blog % bin/gpm selfupgrade

GPM Releases Configuration: Stable

You are already running the latest version of Grav (v1.6.26) released on Mon Jun 8 21:50:49 2020
normawhite@Normas-iMac blog %

My latest download of grav-admin is also this version - with my theme and my pages, archives are also empty.


See the docs on the GPM command:

  • Use $ bin/gpm selfupgrade, to upgrade Grav
  • Use $ bin/gpm update to upgrade themes/plugins

I have just checked again. One more time downloaded blog 2.0 skeleton, ran the two commands you suggested, changed nothing else.
Archives was updated to 2.0.1.
Sadly no archives display in the sidebar.
There does seem to be some talk on GitHub about problems with archives. Did someone fix it and not add it to Grav
e.g. Archive link empty result #23

Does anyone have working archives?


All is working on my localhost:

  • Downloaded skeleton Blog Site

  • Opened the browser -> empty Archives

  • Ran: $ bin/gpm update

  • Refreshed the browser

  • Repeated it on my remote host -> Same result.

Are you sure you refreshed the cache of the browser?

I’m sorry, but I’m out of suggestions now…

I have fixed my original problem in my first version - based on a new grav-admin, adding plugins, replacing pages and copying my theme. The problem was very simple I had forgotten to add the taxonomy plugin:)

As to the gravatastic blog, I even tried a different browser - Chrome instead of Safari - and still no archives.
I wonder if you are starting from the gravatastic blog in or something else. The one there does not work in the demo on the site.

Thanks for all your help.

I’ll try to pretend you didn’t really say this…