RuntimeException error with RHEL7 / HTTPD

Hi all, pretty sure it’s a permissions thing but I’ve been going crazy all day, hoping fresh eyes can help. My httpd service runs as apache user. I configured apache, unzipped a skeleton and got as far as the message in my browser homepage/localhost:80 that says in plain text “for Grav you need PHP 5.6” or something, so great at least it’s seeing it! So I went and upgraded my PHP, that went fine, but now I’m getting 500 errors. I have gone over everything, tried giving all permissions to apache user, ran the commands on the install page (under 1.Basic), still getting no where. I also set /cache and /vendor to 777. This is what httpd is logging:

[Fri Jul 22 18:07:49.807293 2016] [:error] [pid 1279] [client] PHP Fatal error:  Uncaught exception 'RuntimeException' with message 'Creating directory '/var/www/html/cache//compiled/files' failed on error mkdir(): Permission denied' in /var/www/html/vendor/rockettheme/toolbox/File/src/File.php:420
Stack trace:
#0 /var/www/html/vendor/rockettheme/toolbox/File/src/File.php(195): RocketTheme\\Toolbox\\File \\File->mkdir('/var/www/html/c...')
#1 /var/www/html/vendor/rockettheme/toolbox/File/src/File.php(316): RocketTheme\\Toolbox\\File\\File->lock()
#2 /var/www/html/vendor/rockettheme/toolbox/File/src/PhpFile.php(31): RocketTheme\\Toolbox\\File\\File->save(Array)
#3 /var/www/html/system/src/Grav/Common/File/CompiledFile.php(66): RocketTheme\\Toolbox\\File\\PhpFile->save(Array)
#4 /var/www/html/system/src/Grav/Common/Config/Setup.php(165): Grav\\Common\\File\\CompiledYamlFile->content()
#5 /var/www/html/system/src/Grav/Common/Processors/SiteSetupProcessor.php (17): Grav\\Common\\Config\\Setup->init()
#6 /var/www/html/system/src/Grav/Common/Grav.php(121): Grav\\Common\\Processors\\SiteSetupProcessor->process()
#7 /v in /var/www/html/vendor/rockettheme/toolbox/File/src/File.php on line 420

Check the Permissions Troubleshooting Guide

Thank you - I’m still having trouble, hoping you can take a look. Folders are 775, files 664, cache is 777, I have tried every combination of root:apache and root:mygroup, apache:apache and still am still getting the same error I posted above. Restarting httpd each time.