Reg image optimization as per gtmatrix


I am trying to fix the image size issue but not able to do it and not able to understand. Normally, GTmartix also gives the optimized version of images and we need to update on the server to fix it. But in my case, We I upload image on the server it not fix this and keep asking to upload it again.

I tried more than 4-5 times but still not reflecting.

Please help to fix this issue.

Compress your jpgs here:

here is my report and page after compressing with compressjpg.

1 Like is also another similar service.

I already compressed images and uploaded side my theme folder but issue is like GRAV creating temp images in main image folder to use it which already showing needs to be compressed and obtimized. I deleted /images and its generated again but same issue.

Please help.

Optimize the created temp images, and replace the ones that Grav created. The filename MUST be the same. Overwrite the temps with the optimized ones. Should work like a charm.

Not sure how to disable that to be honest. I don’t have that problem with my theme.

Let me try but putting image in temp is too time consuming.

Not really. Empty cache, reload page, and the temps should repopulate themselves.


I have one query / issue with GRAV, Requesting top developers to help us.

As per GTMatrix, Lets consider, logo is not optimized on website, we download the optimized version logo file from report ( as they share optimized files ) and uploaded in actual image folder inside theme. We also deleted/cleared image folder of grav root directory so that it generate it again from theme folder as requied.

But it will not fix image optimized issue. Why ?

If we put image in temp image folder will show its fix :frowning:

Do GRAV increases the image size ? Please help and if any bug in GRAV, Please fix.

1 Like

Any update on it? Solution?