Public session cookie not being set


I have updated to grav 1.6.11 from version 1.3.8 and I have seen that grav-site-* cookie for handling public sessions is not being set. Admin cookie grav-site-*-admin is set properly. How is that possible? Does public session cookie require something in particular?

These are the session settings I have configured:
enabled: true
initialize: true
timeout: 1800
name: grav-site
uniqueness: path
secure: false
httponly: true
split: true


Solved, it was needed to activate a flag on cloudfront to allow cookies