Problems with SSL, Muut Comments and JS w/ Antimatter

I’m having a problem loading the required JS for Muut comments to be enabled on my pages. I’m using the antimatter theme, and in blog_item.html.twig I replaced the original comments section with

<a class="muut" href="{{ page.title }}"></a>
{% do assets.addJs('//') %}

This loads Muut comments just fine on my local vagrant development server. Everything works fine. But when I run my live grav site on my remote server, it doesn’t work correctly, whereas everything else on the site works fine. The moot.min.js file is not loaded on blog_item pages. In fact, it isn’t even called in the html, even though I still have

{% do assets.addJs('//') %}
on the live site. I have SSL enabled on my live server with a 301 redirect for https and www, which works fine. Could this be a problem with SSL? So far I've tried DLing the moot.min.js and loading it locally, but that does work. When I load moot.min.js in base.html.twig, the comments section does not load correctly and look all funky. It  looks like there's an issue with the connection to the CDN where the moot.min.js file is located. I recall having a similar issue loading Yahoo's stock API. When I called the API in js, I had to switch the url to https from http, even though http worked locally. Any thoughts?

If it’s not even loaded in the HTML, it’s not a SSL issue. Can it be because of cache?

@ryankennedy Which version of Grav are you using? Can you try

{% do assets.addJs('') %}

BTW: You can also use , which comes with Muut support out-of-the-box.

JSComments and switching to Disqus worked. Thanks for the suggestion, works great!

Nice! :slight_smile: