Nofollow does not work for img links


#1

In the page linking tutorial, it says you can nofollow Links like this:

[NoFollow Link](../some-page?rel=nofollow)

This does not work when put inside an div container, like :

<div class="div" markdown="1">[![ALT_TEXT](img.jpg)](https://www.website.com/?rel=nofollow)</div>

lg

Niko


#3

@NEA Have you tried using <span> instead of <div> or Markdown Extra?

Using <span>:

<span>
[![ALT_TEXT](unsplash-overcast-mountains.jpg)](https://www.website.com/?rel=nofollow)
</span>

generates…

<span>
<a href="https://www.website.com/" rel="nofollow"><img alt="ALT_TEXT" src="/site-blog/user/pages/01.blog/hero-classes/unsplash-overcast-mountains.jpg"></a>
</span>

See here for explaination: How can I wrap my markdown in an HTML div?

Markdown Extra:
And according to another answer, Markdown Extra does support <div>. Markdown Extra is supported by Grav (see Grav’s Mardown docs):

Grav ships with built-in support for Markdown and Markdown Extra. You must enable Markdown Extra in your system.yaml configuration file.