New plugin with CLI - GPM not reachable

after i enter $bin/plugin devtools new-plugin, it allows me to type the Plugin Name. but it appears " GPM not reachable. Please check your internet connection or check the Grav site is reachable".
openssl & curl are enabled.
when i typed bin/gpm index -f,
it shows "GPM Releases Configuration: Stable
No data was found in the GPM repository stored locally.
Please try clearing cache and running the bin/gpm index -f command again
If this doesn’t work try tweaking your GPM system settings. "

What should i do next? thank you

@flaviocopes could you kindly help?

Looks like PHP cannot connect to the GPM. curl and openssl must be enabled on the CLI version of PHP too, if it’s different from the one loaded by the webserver (it can happen). So make sure it’s loaded (run php -i to check)

curl and openssl both are enabled Php

Did you try all the suggestions listed in the GPM help?

it fixed thank you. i set the HTTP & HTTPS variables. but i also set the Proxy URL in user/system.yaml with old password. that’s why it got problem. i removed the Proxy URL.
thank you for your help :wink: