Installation Error 500

Just wanted to try grav, only get a 500 server error. Tried both - zip package and Git Repo. Running on a Zend Server with PHP 5.5 under Ubuntu 14.04. Only took the Steps in Installation manual…

Was the error like these:

Server Error Docs

Did you happen to look in your logs directory and see what the error was?

Or do you get an Internal Server Error? If so read these docs

BTW You should definitely use the ZIP package from the downloads page. The GitHub package requires the bin/grav install CLI command to download and install the vendor packages. The ZIP already has these.

The Error ist the one you showed in the link yes. My Apache Error log doesnt display anything (tail -f…) opening the Page.
I didn’t have any Problems installing the vendor Packages via bin/grav install anyways…

I checked the log Folder from Grav as well… no files in here :confused:

Well, Running the internal Dev Server via php -S localhost:8000 works fine… Any Issues known about compatiblity with Zend Server?

We have not tried with Zend Server yet, so it could be there’s an issue. My understanding was that Zend was just a repackaging of Apache and PHP, so it should work fine. There is most likely something that needs to be enabled in the server configuration that is not on by default. I’ll try to take a look at the Zend Server CE edition in the next day or two to find out what’s going on.

Well I just spent 30 mins wrestling with and trying to get Zend Server to start, no dice. Says its running but I can’t access it or reach the configuration interface. Also seems there’s no longer a community edition, only a ‘developer edition’ that they charge for per month. I really have no way to debug this at the current time.

If someone else has Zend Server installed and working, that would be appreciated.

The upcoming version of Grav has more explicit and helpful exception handling, so hopefully that will shed some light on the situation too.