How to remove unformatted "Home"

I am using the blog skeleton with Quark theme and unfortunately, the word “home” is standing lonely above the blog items.

Web inspector says, <span itemscope="" itemtype="" itemprop="item" itemid="/de"> <span itemprop="name">Home</span> </span>
Could anybody please help me with that? This is my website: Thanks in advance.

@Olivander12, Always a good idea to show some self-help before asking questions:

  • What have you tried so far?
  • Where did you look for a possible cause?
  • What do your think the purpose is of “Home”?
  • Which theme template, or plugin could insert it into the page?

Give a man a fish…

I have not modified the official skeleton besides editing markdown files. The file looks the following:

title: home
    changefreq: monthly
body_classes: 'header-dark header-transparent'
hero_classes: 'text-light title-h1h2 overlay-dark-gradient hero-large parallax'
hero_image: road.jpg
custom: 'new thing'
blog_url: /blog
show_sidebar: true
show_breadcrumbs: true
show_pagination: true
    items: '@self.children'
    limit: 6
        by: date
        dir: desc
    pagination: true
    url_taxonomy_filters: true
    description: 'Sample Blog Description'
    limit: 10
pagination: true

# Gemeinsam in Horst
## Herzlich Willkommen auf der neuen Homepage

I can delete the title, but then home changes to blog
The title of this file shouldn’t be displayed at all, but I do not know where to disable it.

Edit: I set show_breadcrumbs to false. This helped, but I am not sure if this is a good solution.