How to redirect pages with php extension in GRAV


#21

I honestly don’t know, it works fine on my setup…
Did you clean the cache (grav and browser)? Maybe this’ll help, otherwise you’ll have to wait for one of the main developers…


#22

I’m already setting up a plain vanilla PHP server without Docker.
Maybe that will solve it.

Anyway, thanks for your patience and help.
I got at least one part of my problem solved.

Cheers.


#23

Always happy to help! I’m only sorry that I wasn’t able to help with all the issues…


#24

Got it working now.
It was the php and or grav implementation I used with a Docker container.

I installed a fresh php and grav installation without using a docker container and now url’s ending in .php or any extension are redirected to the home page by setting the route in the error plugin.


#25

Great! I’m really happy to hear this!


#26

Another way would be to extend the .htaccess file to redirect every .php file to achieve this.